Outage in Marana, AZ area West of I-10
Incident Report for Ting Internet
Resolved
This incident has been resolved.
Posted Oct 02, 2024 - 20:41 EDT
Identified
We are currently experiencing a system issue/outage that is affecting customers in the Marana, AZ area. Our engineering team is currently investigating.
Posted Oct 02, 2024 - 18:47 EDT
This incident affected: Arizona (Marana).