Tucson, AZ Simply Bits Weather Related and Power Issues
Incident Report for Ting Internet
Resolved
This incident has been resolved.
Posted Jul 15, 2024 - 13:16 EDT
Identified
Today July 15th, Please be advised the due to harsh Monsoon weather, and TEP Power outages throughout the City we are experiencing Internet System issues. Our Infrastructure Team has been hard at work throughout the evening to restore connectivity. We appreciate your patience and hope to have services restored by Noon Tucson Mountain Time.
Posted Jul 15, 2024 - 08:40 EDT
This incident affected: Arizona (Tucson).