Ting Internet - Live Chat Support Unavailable
Incident Report for Ting Internet
Resolved
We are happy to announce the Live Chat Support system issues, caused by recent updates, have now been fully resolved with Live Chat Support available again. Thanks for your patience while we worked though that.
Posted Oct 17, 2024 - 14:33 EDT
Investigating
We are currently experiencing issues with our Live Chat Support system at Ting.com, where it is unavailable currently for our customers. We are working to restore this as soon as possible, however, in the meantime, please call 1-844-846-4994 (Available 24/7) for live support assistance, or visit https://help.ting.com. We apologize for any inconvenience and we will provide an update on this as soon as one becomes available.
Posted Oct 17, 2024 - 13:41 EDT
This incident affected: Virginia (Charlottesville, VA, Alexandria, VA), North Carolina (Fuquay-Varina, NC, Holly Springs, NC, Wake Forest, NC, Rolesville, NC, Sanford, NC), Idaho (Greater Sandpoint, ID, Ponderay, ID), Maryland (Westminster, MD), Colorado (Aspen, CO, Basalt, CO, Bayfield, CO, Carbondale, CO, Centennial, CO, Cortez, CO, De Beque, CO, Durango, CO, Glenwood Springs, CO, Grand Junction, CO, New Castle, CO, Parachute, CO, Rifle, CO, Silt, CO, Dolores, CO, Colorado Springs, CO), New Mexico (Farmington, NM), California (Culver City, CA, Encinitas, CA, Fullerton, CA, Solana Beach, CA, Carlsbad, CA), Arizona (Tucson, Catalina, Amado, Douglas, Green Valley, Marana, Mt. Lemmon, Nogales, Oracle, Oro Valley, Rio Rico, Sahuarita, San Manuel, Tubac, Vail), and Customer Support, Ting Website, Shop & Your Account, Shipping & Returns.