Minor Outage - Druid Ave - Charlottesville, VA
Incident Report for Ting Internet
Resolved
Service is now restored to the impacted switches. It was determined a power issue caused the problem. If you are still having internet connectivity issues, please reach out to us for individual troubleshooting at 1-844-846-4994.

Thank you
Posted Nov 07, 2023 - 09:51 EST
Investigating
We are currently investigating an issue impacting one of our multiple dwelling unit locations around Druid Ave in Charlottesville. The switches servicing this location in particular are currently not communicating. This impact is approximately 20 customers currently offline. We will update here once we have further information.

Thank you for your patience.
Posted Nov 07, 2023 - 08:20 EST
This incident affected: Virginia (Charlottesville, VA).