Ting Internet - Wake Forest - Issues with connection

Incident Report for Ting Internet

Resolved

We were able to identify the issue and resolve it quickly. Thank you for your patience as we resolved the issue.
Posted Apr 18, 2025 - 01:30 EDT

Investigating

We are currently investigating an issue where customers are having issues connecting to the internet. Please stand by and be patient as we investigate the issue. We will update this as more information becomes available.
Posted Apr 18, 2025 - 01:12 EDT
This incident affected: North Carolina (Wake Forest, NC).