Simply Bits - Tucson, AZ (Oak Creek area)
Incident Report for Ting Internet
Resolved
This incident has been resolved.
Posted Jul 25, 2024 - 13:25 EDT
Identified
We are currently experiencing system issues in the area of Oak Creek. Customers in this area may experience Intermittent connectivity. We have identified the issue and are working towards a swift resolution.
Posted Jul 19, 2024 - 17:47 EDT
This incident affected: Arizona (Tucson).