Tucson Electric Power (TEP) Maintenance October 24th - 8pm -through 6am October 25th
Incident Report for Ting Internet
Resolved
This incident has been resolved.
Posted Oct 25, 2024 - 12:21 EDT
Identified
Please be advised that TEP (Tucson Electric Power Company) will be performing Maintenance in the Downtown Tucson area as follows:

East and West of I-10 and Congress St., North of E. Broadway up to the Rillito Park area South of E. Broadway to I-19 and W. Irvington Rd.

This will result in loss of power to our Downtown Tower and an outage during this time frame.
Posted Oct 24, 2024 - 14:50 EDT
This incident affected: Arizona (Tucson).