Tucson, AZ - Commercial Customer Fax issues
Incident Report for Ting Internet
Resolved
This issue has been resolved, and we continue to monitor the situation.
Posted Jul 15, 2024 - 12:24 EDT
Identified
We are currently experiencing an issue relating to our Fax system. The issue has been identified, and our VoIP Engineering Team is working on a resolution. We apologize for the inconvenience, but will work as swiftly as possible to resolve the issue affecting Fax errors.
Posted Jul 12, 2024 - 17:58 EDT
This incident affected: Arizona (Tucson).