Slow/Intermittent Connections surrounding Mountain View High School
Incident Report for Ting Internet
Resolved
This issue has been resolved and customers should be experiencing normal internet connectivity and speeds
Posted Nov 16, 2023 - 18:21 EST
Investigating
We are currently investigating an issue that is impacting our Mountain View High School Site. Customers service by this site may experience slower then normal speeds and intermittent connectivity. At this time the issue is still under investigation and as such we do not have an ETA for resolution. Updates will be posted as more information becomes available
Posted Nov 16, 2023 - 16:45 EST
This incident affected: Arizona (Tucson).