The majority of repairs in this area have been completed and services are back online, but for one home where ongoing tree removal efforts meant we were unable to access our equipment. Or team will be returning in the morning tomorrow to finalize repairs there and the resident involved has been contacted. If you have NOT been contacted and are still seeing an ongoing issue, please get in touch at 1-844-846-4994 so we can take a deeper look.
Posted Oct 31, 2024 - 16:27 EDT
Investigating
We have reports of a likely fiber strike near the 2500 block of Huntington Rd in Charlottesville VA, with about a dozen homes affected and currently offline nearby. Techs have been dispatched and are in transit as of this writing. We have no ETA on the repair yet but one will be provided here as soon as it is available.
Posted Oct 31, 2024 - 12:52 EDT
This incident affected: Virginia (Charlottesville, VA).