Simply Bits System Outage
Incident Report for Ting Internet
Resolved
This incident has been resolved.
Posted Apr 24, 2024 - 18:59 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 24, 2024 - 17:22 EDT
Identified
Simply Bits is currently experiencing system issues that is affecting phones and internet connectivity. Our Engineering Team is investigating and working towards a swift resolution. . We apologize for the inconvinience, but appreciate your patience during the investigation and repar.
Posted Apr 24, 2024 - 16:21 EDT
This incident affected: Arizona (Tucson).